Imported Custom Rules Not Listed Under Custom Profile

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Imported Custom Rules Not Listed Under Custom Profile

PrathameshMB
Hi,

Please pardon me if the question has been posted earlier, but i could not find any. Hence Posting a fresh.

Here is my case:

1. Created a Custom Profile a Custom Language say json.

2. Uploaded following XML file using Restore Profile:
<profile>
        <name>Test JSON Profile</name>
        <language>json</language>
        <rules>
                <rule>
                        <repositoryKey>json</repositoryKey>
                        <key>json:001</key>
                        <priority>MAJOR</priority>
                        <parameters />
                </rule>
        </rules>
</profile>
3. As shown below now the JSON language has one more Profile : Test JSON Profile.


As shown in the image, the profile still has Zero rules. I tried to restart the server and was hoping to see the rule count getting reflected as 1. But no luck.

Am i missing anything or doing anything wrong while uploading custom rules through XML.

If i try to add custom rules through coding, the rules are getting reflected.

Any help is much appreciated.

Regards,
Prathamesh
Reply | Threaded
Open this post in threaded view
|

Re: [sonar-dev] Imported Custom Rules Not Listed Under Custom Profile

Julien Lancelot
Hi,

Indeed, it's not possible to import custom rules.
Feel free to vote for this JIRA ticket : https://jira.codehaus.org/browse/SONAR-5366

Regards,

Julien LANCELOT | SonarSource

On 4 May 2015 at 14:20, PrathameshMB <[hidden email]> wrote:
Hi,

Please pardon me if the question has been posted earlier, but i could not
find any. Hence Posting a fresh.

Here is my case:

1. Created a Custom Profile a Custom Language say json.
<http://sonarqube.15.x6.nabble.com/file/n5034943/JSON_Profile.png>
2. Uploaded following XML file using Restore Profile:
<profile>
        <name>Test JSON Profile</name>
        <language>json</language>
        <rules>
                <rule>
                        <repositoryKey>json</repositoryKey>
                        <key>json:001</key>
                        <priority>MAJOR</priority>
                        <parameters />
                </rule>
        </rules>
</profile>
3. As shown below now the JSON language has one more Profile : Test JSON
Profile.
<http://sonarqube.15.x6.nabble.com/file/n5034943/JSON_Profile_AfterUpdate.png>

As shown in the image, the profile still has Zero rules. I tried to restart
the server and was hoping to see the rule count getting reflected as 1. But
no luck.

Am i missing anything or doing anything wrong while uploading custom rules
through XML.

If i try to add custom rules through coding, the rules are getting
reflected.

Any help is much appreciated.

Regards,
Prathamesh



--
View this message in context: http://sonarqube.15.x6.nabble.com/Imported-Custom-Rules-Not-Listed-Under-Custom-Profile-tp5034943.html
Sent from the SonarQube Developers mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email