Need To Update Database Error SonarQube 4.3.1

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Need To Update Database Error SonarQube 4.3.1

Kyle Smith
Hello SonarQube Users,

I am trying to update from a previous version of SonarQube to 4.3.1. This seemed to work for the most part except for the last part when going to this page: http://localhost:9000/setup

After clicking the button 'Upgrade' the database tries to work with the new version but then fails with an JDBC error.

The log files say that: Database must be upgraded. Please browse /setup

Further down the log file the output says: ERROR [o.s.s.ui.JRubyFacade] Fail to upgrade database
        An error has occurred, all later migrations canceled:


I am using Red Hat, with MySQL but MySQL is really MariaDB. My MariaDB version is 10.0.4-MariaDB-log MariaDB Server.

Can anyone help me upgrade please? Thanks for reading.

Reply | Threaded
Open this post in threaded view
|

Re: Need To Update Database Error SonarQube 4.3.1

Kyle Smith
I should add that the error on the setup page points to a specific type of Ruby error with, "  ActiveRecord::JDBCError"

Googling, " ActiveRecord::JDBCError" shows that this is normally found in Ruby programming.
Reply | Threaded
Open this post in threaded view
|

Re: Need To Update Database Error SonarQube 4.3.1

Julien Lancelot
Hi,

First, you have to know that MariaDB is not in the supported databases : http://docs.codehaus.org/display/SONAR/Requirements
Then, to try to help you, you'll need to send us the sonar.log file please.

Regards,
Julien LANCELOT | SonarSource


On 10 June 2014 23:23, What_Just_Happened <[hidden email]> wrote:
I should add that the error on the setup page points to a specific type of
Ruby error with, "  ActiveRecord::JDBCError"

Googling, " ActiveRecord::JDBCError" shows that this is normally found in
Ruby programming.



--
View this message in context: http://sonarqube.15.x6.nabble.com/Need-To-Update-Database-Error-SonarQube-4-3-1-tp5025616p5025619.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: Need To Update Database Error SonarQube 4.3.1

Kyle Smith
Julien,

Thank-you for the quick feedback. I was able to get an updated version of SonarQube working with a compatible DBMS.

Thank-you again for the helpful feedback.

It was especially confusing since MariaDB is the mysql DBMS on the Red Hat operating system I am using.

Reply | Threaded
Open this post in threaded view
|

Re: Need To Update Database Error SonarQube 4.3.1

Julien Lancelot
Good to know that it's working!

Regards,

Julien LANCELOT | SonarSource


On 13 June 2014 18:20, What_Just_Happened <[hidden email]> wrote:
Julien,

Thank-you for the quick feedback. I was able to get an updated version of
/SonarQube/ working with a compatible DBMS.

Thank-you again for the helpful feedback.

It was especially confusing since MariaDB is the mysql DBMS on the Red Hat
operating system I am using.





--
View this message in context: http://sonarqube.15.x6.nabble.com/Need-To-Update-Database-Error-SonarQube-4-3-1-tp5025616p5025737.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email