No 'On New Code' in dashboard test coverage widget

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

No 'On New Code' in dashboard test coverage widget

Shengyuan Lu
Hello,

I couldn't find 'On New Code' in Sonar dashboard test coverage widget.
And I find out page Lack of Unit Tests where 'On New Code' is displayed, but mine doesn't have 'On New Code' in dashboard widget.
I guess something I configured incorrectly causes the problem.
Anyone could give me suggestion for the problem?
Thanks in advance!

My environment:
sonar version: 5.1
maven command:
> mvn clean org.jacoco:jacoco-maven-plugin:prepare-agent install -Dmaven.test.failure.ignore=true
> mvn sonar:sonar

Best Regards,
Shengyuan
Reply | Threaded
Open this post in threaded view
|

RE: No 'On New Code' in dashboard test coverage widget

Shengyuan Lu
Hi,

My original mail may not be clear. here's my snapshot, where there is not 'On New Code' information:
<script type="jsv#846_"></script>  
 
<script type="jsv/846_"></script>


How could I configure the 'On New Code' on the coverage widget? Something about SCM?
Thanks!

Shengyuan


From: [hidden email]
To: [hidden email]
Date: Fri, 8 May 2015 17:10:53 +0800
Subject: [sonar-user] No 'On New Code' in dashboard test coverage widget

Hello,

I couldn't find 'On New Code' in Sonar dashboard test coverage widget.
And I find out page Lack of Unit Tests where 'On New Code' is displayed, but mine doesn't have 'On New Code' in dashboard widget.
I guess something I configured incorrectly causes the problem.
Anyone could give me suggestion for the problem?
Thanks in advance!

My environment:
sonar version: 5.1
maven command:
> mvn clean org.jacoco:jacoco-maven-plugin:prepare-agent install -Dmaven.test.failure.ignore=true
> mvn sonar:sonar

Best Regards,
Shengyuan
Reply | Threaded
Open this post in threaded view
|

Re: No 'On New Code' in dashboard test coverage widget

Julien HENRY
Hi Shengyuan,

The "On new code" feature is depending on the SCM blame feature. What is your SCM? Do you have the correct SCM plugin installed/configured? Can you share analysis logs?

++

Julien

2015-05-11 4:59 GMT+02:00 Shengyuan Lu <[hidden email]>:
Hi,

My original mail may not be clear. here's my snapshot, where there is not 'On New Code' information:
 
 


How could I configure the 'On New Code' on the coverage widget? Something about SCM?
Thanks!

Shengyuan


From: [hidden email]
To: [hidden email]
Date: Fri, 8 May 2015 17:10:53 +0800
Subject: [sonar-user] No 'On New Code' in dashboard test coverage widget


Hello,

I couldn't find 'On New Code' in Sonar dashboard test coverage widget.
And I find out page Lack of Unit Tests where 'On New Code' is displayed, but mine doesn't have 'On New Code' in dashboard widget.
I guess something I configured incorrectly causes the problem.
Anyone could give me suggestion for the problem?
Thanks in advance!

My environment:
sonar version: 5.1
maven command:
> mvn clean org.jacoco:jacoco-maven-plugin:prepare-agent install -Dmaven.test.failure.ignore=true
> mvn sonar:sonar

Best Regards,
Shengyuan

Reply | Threaded
Open this post in threaded view
|

Re: No 'On New Code' in dashboard test coverage widget

G. Ann Campbell
Also, the "On New Code" section of the widget only shows up when a differential is applied



---
G. Ann CAMPBELL | SonarSource
Product Owner

On Mon, May 11, 2015 at 3:36 AM, Julien HENRY <[hidden email]> wrote:
Hi Shengyuan,

The "On new code" feature is depending on the SCM blame feature. What is your SCM? Do you have the correct SCM plugin installed/configured? Can you share analysis logs?

++

Julien

2015-05-11 4:59 GMT+02:00 Shengyuan Lu <[hidden email]>:
Hi,

My original mail may not be clear. here's my snapshot, where there is not 'On New Code' information:
 
 


How could I configure the 'On New Code' on the coverage widget? Something about SCM?
Thanks!

Shengyuan


From: [hidden email]
To: [hidden email]
Date: Fri, 8 May 2015 17:10:53 +0800
Subject: [sonar-user] No 'On New Code' in dashboard test coverage widget


Hello,

I couldn't find 'On New Code' in Sonar dashboard test coverage widget.
And I find out page Lack of Unit Tests where 'On New Code' is displayed, but mine doesn't have 'On New Code' in dashboard widget.
I guess something I configured incorrectly causes the problem.
Anyone could give me suggestion for the problem?
Thanks in advance!

My environment:
sonar version: 5.1
maven command:
> mvn clean org.jacoco:jacoco-maven-plugin:prepare-agent install -Dmaven.test.failure.ignore=true
> mvn sonar:sonar

Best Regards,
Shengyuan


Reply | Threaded
Open this post in threaded view
|

RE: No 'On New Code' in dashboard test coverage widget

Shengyuan Lu
Hi Ann,

I am using git as SCM, and configured it in 'SCM' of Sonar. But it doesn't work. 
And there is no 'blame' information on source code view.

  • The log seems OK as follows:

[INFO] [14:36:46.058] Sensor SCM Sensor
[INFO] [14:36:46.060] Sensor SCM Sensor (done) | time=2ms



  • The Settings are as follows:

<script type="jsv#3153_"></script>  
 <script type="jsv/3153_"></script>


Do I miss something?


Regards,
Shengyuan Lu

Date: Tue, 12 May 2015 11:26:28 -0400
From: [hidden email]
To: [hidden email]
Subject: Re: [sonar-user] No 'On New Code' in dashboard test coverage widget

Also, the "On New Code" section of the widget only shows up when a differential is applied



---
G. Ann CAMPBELL | SonarSource
Product Owner

On Mon, May 11, 2015 at 3:36 AM, Julien HENRY <[hidden email]> wrote:
Hi Shengyuan,

The "On new code" feature is depending on the SCM blame feature. What is your SCM? Do you have the correct SCM plugin installed/configured? Can you share analysis logs?

++

Julien

2015-05-11 4:59 GMT+02:00 Shengyuan Lu <[hidden email]>:
Hi,

My original mail may not be clear. here's my snapshot, where there is not 'On New Code' information:
 
 


How could I configure the 'On New Code' on the coverage widget? Something about SCM?
Thanks!

Shengyuan


From: [hidden email]
To: [hidden email]
Date: Fri, 8 May 2015 17:10:53 +0800
Subject: [sonar-user] No 'On New Code' in dashboard test coverage widget


Hello,

I couldn't find 'On New Code' in Sonar dashboard test coverage widget.
And I find out page Lack of Unit Tests where 'On New Code' is displayed, but mine doesn't have 'On New Code' in dashboard widget.
I guess something I configured incorrectly causes the problem.
Anyone could give me suggestion for the problem?
Thanks in advance!

My environment:
sonar version: 5.1
maven command:
> mvn clean org.jacoco:jacoco-maven-plugin:prepare-agent install -Dmaven.test.failure.ignore=true
> mvn sonar:sonar

Best Regards,
Shengyuan


Reply | Threaded
Open this post in threaded view
|

RE: No 'On New Code' in dashboard test coverage widget

Shengyuan Lu
Hi Ann,

I fixed the problem just now.
Maven SCM settings was added correctly, then it works. See: https://maven.apache.org/pom.html#SCM

By the way, would you add the POM settings in Sonar Wiki? To make Sonar users life easier:)

Thanks for your response!
Shengyuan

From: [hidden email]
To: [hidden email]
Date: Mon, 18 May 2015 14:52:57 +0800
Subject: RE: [sonar-user] No 'On New Code' in dashboard test coverage widget

Hi Ann,

I am using git as SCM, and configured it in 'SCM' of Sonar. But it doesn't work. 
And there is no 'blame' information on source code view.

  • The log seems OK as follows:

[INFO] [14:36:46.058] Sensor SCM Sensor
[INFO] [14:36:46.060] Sensor SCM Sensor (done) | time=2ms



  • The Settings are as follows:

 
 


Do I miss something?


Regards,
Shengyuan Lu

Date: Tue, 12 May 2015 11:26:28 -0400
From: [hidden email]
To: [hidden email]
Subject: Re: [sonar-user] No 'On New Code' in dashboard test coverage widget

Also, the "On New Code" section of the widget only shows up when a differential is applied



---
G. Ann CAMPBELL | SonarSource
Product Owner

On Mon, May 11, 2015 at 3:36 AM, Julien HENRY <[hidden email]> wrote:
Hi Shengyuan,

The "On new code" feature is depending on the SCM blame feature. What is your SCM? Do you have the correct SCM plugin installed/configured? Can you share analysis logs?

++

Julien

2015-05-11 4:59 GMT+02:00 Shengyuan Lu <[hidden email]>:
Hi,

My original mail may not be clear. here's my snapshot, where there is not 'On New Code' information:
 
 


How could I configure the 'On New Code' on the coverage widget? Something about SCM?
Thanks!

Shengyuan


From: [hidden email]
To: [hidden email]
Date: Fri, 8 May 2015 17:10:53 +0800
Subject: [sonar-user] No 'On New Code' in dashboard test coverage widget


Hello,

I couldn't find 'On New Code' in Sonar dashboard test coverage widget.
And I find out page Lack of Unit Tests where 'On New Code' is displayed, but mine doesn't have 'On New Code' in dashboard widget.
I guess something I configured incorrectly causes the problem.
Anyone could give me suggestion for the problem?
Thanks in advance!

My environment:
sonar version: 5.1
maven command:
> mvn clean org.jacoco:jacoco-maven-plugin:prepare-agent install -Dmaven.test.failure.ignore=true
> mvn sonar:sonar

Best Regards,
Shengyuan