Problem Building Sonar

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem Building Sonar

GarethBurns
Hi Guys,

I'm hoping someone can help with this. I am trying to build the source code for Sonar using Maven and I have followed all of the instructions on the Sonar site. I have tried the quick-build.sh approach but I receive an error and I am totally stumped. The error I get is as follows.

[ERROR] Failed to execute goal on project sonar-application: Could not resolve dependencies for project org.codehaus.sonar:sonar-application:jar:3.3-SNAPSHOT: The following artifacts could not be resolved: org.codehaus.sonar-plugins.java:sonar-squid-java-plugin:jar:1.0-SNAPSHOT, org.codehaus.sonar-plugins.java:sonar-java-plugin:jar:1.0-SNAPSHOT: Could not find artifact org.codehaus.sonar-plugins.java:sonar-squid-java-plugin:jar:1.0-SNAPSHOT -> [Help 1]

Have I missed a configuration option in the POM for dependencies or is there something else I am obviously missing? I searched the message board before submitting this but couldn't find anything relating to this error.

Thanks in advance for your help.
G
Reply | Threaded
Open this post in threaded view
|

Re: [sonar-dev] Problem Building Sonar

Simon Brandhof
Hi,

You have to build https://github.com/SonarSource/sonar-java/.
This SNAPSHOT dependency will probably be replaced by a RELEASE one after the release of sonar 3.3.

Regards

On 11 October 2012 16:32, GarethBurns <[hidden email]> wrote:
Hi Guys,

I'm hoping someone can help with this. I am trying to build the source code
for Sonar using Maven and I have followed all of the instructions on the
Sonar site. I have tried the quick-build.sh approach but I receive an error
and I am totally stumped. The error I get is as follows.

*[ERROR] Failed to execute goal on project sonar-application: Could not
resolve dependencies for project
org.codehaus.sonar:sonar-application:jar:3.3-SNAPSHOT: The following
artifacts could not be resolved:
org.codehaus.sonar-plugins.java:sonar-squid-java-plugin:jar:1.0-SNAPSHOT,
org.codehaus.sonar-plugins.java:sonar-java-plugin:jar:1.0-SNAPSHOT: Could
not find artifact
org.codehaus.sonar-plugins.java:sonar-squid-java-plugin:jar:1.0-SNAPSHOT ->
[Help 1]*

Have I missed a configuration option in the POM for dependencies or is there
something else I am obviously missing? I searched the message board before
submitting this but couldn't find anything relating to this error.

Thanks in advance for your help.
G



--
View this message in context: http://sonar.15.n6.nabble.com/Problem-Building-Sonar-tp5003953.html
Sent from the Sonar dev mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--

Simon BRANDHOF | SonarSource
http://sonarsource.com

Reply | Threaded
Open this post in threaded view
|

Re: [sonar-dev] Problem Building Sonar

Javier Londoño
In reply to this post by GarethBurns
Hi.
 
Another option for this error is:  add http://repository-sonarplugins.forge.cloudbees.com/snapshot/ repository, or to compile this project before : https://github.com/SonarSource/sonar-java
 
Regards!!!

2012/10/11 GarethBurns <[hidden email]>
Hi Guys,

I'm hoping someone can help with this. I am trying to build the source code
for Sonar using Maven and I have followed all of the instructions on the
Sonar site. I have tried the quick-build.sh approach but I receive an error
and I am totally stumped. The error I get is as follows.

*[ERROR] Failed to execute goal on project sonar-application: Could not
resolve dependencies for project
org.codehaus.sonar:sonar-application:jar:3.3-SNAPSHOT: The following
artifacts could not be resolved:
org.codehaus.sonar-plugins.java:sonar-squid-java-plugin:jar:1.0-SNAPSHOT,
org.codehaus.sonar-plugins.java:sonar-java-plugin:jar:1.0-SNAPSHOT: Could
not find artifact
org.codehaus.sonar-plugins.java:sonar-squid-java-plugin:jar:1.0-SNAPSHOT ->
[Help 1]*

Have I missed a configuration option in the POM for dependencies or is there
something else I am obviously missing? I searched the message board before
submitting this but couldn't find anything relating to this error.

Thanks in advance for your help.
G



--
View this message in context: http://sonar.15.n6.nabble.com/Problem-Building-Sonar-tp5003953.html
Sent from the Sonar dev mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
Cordialmente
 
Javier O. Londoño C.

Reply | Threaded
Open this post in threaded view
|

Re: Problem Building Sonar

GarethBurns
In reply to this post by GarethBurns
Sorted!
Thanks Guys,
G