SCM Activity Plugin not working

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

SCM Activity Plugin not working

satishKaRohini
I am using svn as a source repository and am interested in using the "code coverage" for new code feature of sonar.
I learnt that we have to just install the plugin and ensure that svn is installed on server where analysis is run.
I did that but do not see the coverage for new code.

I read  various blogs and could not find a solution.
I can see below in my logs which I assume, means plugin installed fine

2014.08.27 17:26:40 INFO  o.s.s.p.PluginDeployer  Deploy plugin SCM Activity / 1.6 /
2014.08.27 17:26:41 INFO  org.sonar.INFO  Install plugins done: 1150 ms

Can somebody suggest what I may be missing.
The sonar server is installed on a machine which I do not have access to. I have a access to the website version of sonar(though which I add quality profile and other things)

Thanks for reading this,
Satish
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

G. Ann Campbell
The SCM Activity plugin is designed to show commit/blame data next to the code. It has nothing to do with coverage.





---
G. Ann CAMPBELL | SonarSource
Product Owner

On Tue, Oct 21, 2014 at 7:08 AM, satishKaRohini <[hidden email]> wrote:
I am using svn as a source repository and am interested in using the "code
coverage" for new code feature of sonar.
I learnt that we have to just install the plugin and ensure that svn is
installed on server where analysis is run.
I did that but do not see the coverage for new code.

I read  various blogs and could not find a solution.
I can see below in my logs which I assume, means plugin installed fine

<a href="tel:2014.08.27%2017" value="+12014082717">2014.08.27 17:26:40 INFO  o.s.s.p.PluginDeployer  Deploy plugin SCM Activity
/ 1.6 /
<a href="tel:2014.08.27%2017" value="+12014082717">2014.08.27 17:26:41 INFO  org.sonar.INFO  Install plugins done: 1150 ms

Can somebody suggest what I may be missing.
The sonar server is installed on a machine which I do not have access to. I
have a access to the website version of sonar(though which I add quality
profile and other things)

Thanks for reading this,
Satish



--
View this message in context: http://sonarqube.15.x6.nabble.com/SCM-Activity-Plugin-not-working-tp5029281.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

David RACODON
Hi Satish, Hi Ann,

To get code coverage on new code, indeed, you have to install the SCM Activity plugin: http://docs.codehaus.org/display/SONAR/SCM+Activity+Plugin

Then, just run some analyses on your code (and your code with some changes) and you should get the blame information and thus the code coverage on new code.
If you don't get blame information, please send the log file of your analysis.

Thank you

David

On Tue, Oct 21, 2014 at 10:13 PM, G. Ann Campbell <[hidden email]> wrote:
The SCM Activity plugin is designed to show commit/blame data next to the code. It has nothing to do with coverage.





---
G. Ann CAMPBELL | SonarSource
Product Owner

On Tue, Oct 21, 2014 at 7:08 AM, satishKaRohini <[hidden email]> wrote:
I am using svn as a source repository and am interested in using the "code
coverage" for new code feature of sonar.
I learnt that we have to just install the plugin and ensure that svn is
installed on server where analysis is run.
I did that but do not see the coverage for new code.

I read  various blogs and could not find a solution.
I can see below in my logs which I assume, means plugin installed fine

<a href="tel:2014.08.27%2017" value="+12014082717" target="_blank">2014.08.27 17:26:40 INFO  o.s.s.p.PluginDeployer  Deploy plugin SCM Activity
/ 1.6 /
<a href="tel:2014.08.27%2017" value="+12014082717" target="_blank">2014.08.27 17:26:41 INFO  org.sonar.INFO  Install plugins done: 1150 ms

Can somebody suggest what I may be missing.
The sonar server is installed on a machine which I do not have access to. I
have a access to the website version of sonar(though which I add quality
profile and other things)

Thanks for reading this,
Satish



--
View this message in context: http://sonarqube.15.x6.nabble.com/SCM-Activity-Plugin-not-working-tp5029281.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email






--
David RACODON
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

Patroklos Papapetrou
And just to make sure that it's clear 
You need to pick up a differential date to show the coverage on new code :)

Regards

Patroklos Papapetrou

SoftwareGarden.io

Linkedin | Twitter | Author Speaker | Blog | Google+ | GitHub |



On Wed, Oct 22, 2014 at 9:16 AM, David Racodon <[hidden email]> wrote:
Hi Satish, Hi Ann,

To get code coverage on new code, indeed, you have to install the SCM Activity plugin: http://docs.codehaus.org/display/SONAR/SCM+Activity+Plugin

Then, just run some analyses on your code (and your code with some changes) and you should get the blame information and thus the code coverage on new code.
If you don't get blame information, please send the log file of your analysis.

Thank you

David

On Tue, Oct 21, 2014 at 10:13 PM, G. Ann Campbell <[hidden email]> wrote:
The SCM Activity plugin is designed to show commit/blame data next to the code. It has nothing to do with coverage.





---
G. Ann CAMPBELL | SonarSource
Product Owner

On Tue, Oct 21, 2014 at 7:08 AM, satishKaRohini <[hidden email]> wrote:
I am using svn as a source repository and am interested in using the "code
coverage" for new code feature of sonar.
I learnt that we have to just install the plugin and ensure that svn is
installed on server where analysis is run.
I did that but do not see the coverage for new code.

I read  various blogs and could not find a solution.
I can see below in my logs which I assume, means plugin installed fine

<a href="tel:2014.08.27%2017" value="+12014082717" target="_blank">2014.08.27 17:26:40 INFO  o.s.s.p.PluginDeployer  Deploy plugin SCM Activity
/ 1.6 /
<a href="tel:2014.08.27%2017" value="+12014082717" target="_blank">2014.08.27 17:26:41 INFO  org.sonar.INFO  Install plugins done: 1150 ms

Can somebody suggest what I may be missing.
The sonar server is installed on a machine which I do not have access to. I
have a access to the website version of sonar(though which I add quality
profile and other things)

Thanks for reading this,
Satish



--
View this message in context: http://sonarqube.15.x6.nabble.com/SCM-Activity-Plugin-not-working-tp5029281.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email






--
David RACODON

Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

satishKaRohini
Hi,
I am not able to see the blame information. I am using sonar 3.7.3.
Please find attached the logs.

I also see this on the website:
In order for this(i.e. SCM Activity Plugin) to work, the sonar-project.properties file needs to be located in a checked-out folder, but it does not have to be checked-in.
Alternatively, you can set the "sonar.projectBaseDir" property to a checked-in folder (requires sonar-runner 2.4 at least), and have the sonar-project.properties files located anywhere.

I suppose this file (sonar-project.properties) needs to be there where the code is kept. Does it need to be in same location as my main pom.xml.

As mentioned I am working with a client provided sonar installation and I have access to only the web version. I am in a different geography as compared to sonar installation location.

Thanks,
Satishsonarupdated.log
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

David RACODON
Hi,

Could you please provide the log file of your analysis to investigate (output of the sonar-runner command)?
Also, what is the version of SVN?

Thank you

David


On Wed, Oct 22, 2014 at 12:32 PM, satishKaRohini <[hidden email]> wrote:
Hi,
I am not able to see the blame information. I am using sonar 3.7.3.
Please find attached the logs.

I also see this on the website:
In order for this(i.e. SCM Activity Plugin) to work, the
sonar-project.properties file needs to be located in a checked-out folder,
but it does not have to be checked-in.
Alternatively, you can set the "sonar.projectBaseDir" property to a
checked-in folder (requires sonar-runner 2.4 at least), and have the
sonar-project.properties files located anywhere.

I suppose this file (sonar-project.properties) needs to be there where the
code is kept. Does it need to be in same location as my main pom.xml.

As mentioned I am working with a client provided sonar installation and I
have access to only the web version. I am in a different geography as
compared to sonar installation location.

Thanks,
Satish sonarupdated.log
<http://sonarqube.15.x6.nabble.com/file/n5029314/sonarupdated.log>



--
View this message in context: http://sonarqube.15.x6.nabble.com/SCM-Activity-Plugin-not-working-tp5029281p5029314.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
David RACODON
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

satishKaRohini
Hi,
I am using sonar 3.7.3
I am not sure of the meaning of below line:
Could you please provide the log file of your analysis to investigate (output of the sonar-runner command)?

Is there any specific command I have to run to generate the logs?
By analysis, you mean I have to check my self the logs (output of the sonar-runner command) and share the analysis. Am I correct?

I am sorry if I am asking basic question.

Thanks,
Satish
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

David RACODON
Hi Satish,

I just need the output of the sonar-runner command.

Regards,

David

On Mon, Oct 27, 2014 at 9:14 AM, satishKaRohini <[hidden email]> wrote:
Hi,
I am using sonar 3.7.3
I am not sure of the meaning of below line:
Could you please provide the log file of your analysis to investigate
(output of the sonar-runner command)?

Is there any specific command I have to run to generate the logs?
By analysis, you mean I have to check my self the logs (output of the
sonar-runner command) and share the analysis. Am I correct?

I am sorry if I am asking basic question.

Thanks,
Satish




--
View this message in context: http://sonarqube.15.x6.nabble.com/SCM-Activity-Plugin-not-working-tp5029281p5029403.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
David RACODON
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

satishKaRohini
Hi,
The project is using Bamboo for integrating with sonar. Thus I am not sure how do I get this output. Do you have any suggestions.
The sonar and bamboo installed is managed by another group in another geography.
I do have access to the sonar logs though.


Thanks,
Satish
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

David RACODON
Hi Satish,

The logs of the SonarQube server are useless to investigate your issue.
I would need the log of the SonarQube analysis that can be retrieved from Bamboo.

Regards,

David

On Mon, Oct 27, 2014 at 2:50 PM, satishKaRohini <[hidden email]> wrote:
Hi,
The project is using Bamboo for integrating with sonar. Thus I am not sure
how do I get this output. Do you have any suggestions.
The sonar and bamboo installed is managed by another group in another
geography.
I do have access to the sonar logs though.


Thanks,
Satish



--
View this message in context: http://sonarqube.15.x6.nabble.com/SCM-Activity-Plugin-not-working-tp5029281p5029414.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
David RACODON
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

satishKaRohini
Hi David,
I am attaching sonar analysis logs. I have stripped of un-related information due to our company security requirements.
I can see some authorization failed (http://<svnservername>)

I checked the user with which the sonar analysis is run. There was no such user and thus I created user by same name and made it administrator in sonarcube users.

I ran the analysis again and I still see same issues.

Thanks,
Satishsonarlogupdated.log
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

satishKaRohini
In reply to this post by David RACODON
Hi David,
Can you please let me know if there are any suggestions. I am not able to make any progress and it is pretty urgent for my work. It will be great help if I can get some guidance.

Thanks,
Satish
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

David RACODON
Hi Satish,

You have to go to Settings > General Settings > SCM Activity and set the "User" and "Password" property to the credentials of a user who can access your SVN repository.

Regards,

David

On Thu, Oct 30, 2014 at 10:03 AM, satishKaRohini <[hidden email]> wrote:
Hi David,
Can you please let me know if there are any suggestions. I am not able to
make any progress and it is pretty urgent for my work. It will be great help
if I can get some guidance.

Thanks,
Satish



--
View this message in context: http://sonarqube.15.x6.nabble.com/SCM-Activity-Plugin-not-working-tp5029281p5029557.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
David RACODON
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

satishKaRohini
Hi David,
Thanks a lot. It worked after following your suggestion.

Satish
Reply | Threaded
Open this post in threaded view
|

Re: SCM Activity Plugin not working

David RACODON
Cool! Thanks for the notification.

On Fri, Oct 31, 2014 at 8:07 AM, satishKaRohini <[hidden email]> wrote:
Hi David,
Thanks a lot. It worked after following your suggestion.

Satish



--
View this message in context: http://sonarqube.15.x6.nabble.com/SCM-Activity-Plugin-not-working-tp5029281p5029608.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
David RACODON