Sonar Analysis Issue after Upgrade

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Sonar Analysis Issue after Upgrade

jbdundas
HI All,

We upgrade our server from 3.7 to 4.2  yesterday and we seem to be unable to run any analysis . The stacktrace(sonarUpgradeExecutionLog.txt) and other needed files are with the email.

As you can see, all the permissions have been provided for in the server. Also, there is a problem in running the analysis only when the user id other than admin/admin . If we use any other user id/pwassword , then it fails with a "Not authorized. Please check the properties sonar.login and sonar.password"

Can you please help us out?

Thanks & Regards,
Jitesh Dundas

Phone - 732-357-6292





---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

sonarupgradeExecutionLog.txt (12K) Download Attachment
sonar-project.properties (706 bytes) Download Attachment
soanr_upgrade_error_7Apr2014_p2.PNG (207K) Download Attachment
soanr_upgrade_error_7Apr2014_p1.PNG (188K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Sonar Analysis Issue after Upgrade

jbdundas
Hello All,

Does anyone have any idea of the issue below? Is this a bug in the current latest version?



Thanks & Regards,
Jitesh Dundas

Phone - 732-357-6292





On Mon, Apr 7, 2014 at 10:25 AM, jitesh dundas <[hidden email]> wrote:
HI All,

We upgrade our server from 3.7 to 4.2  yesterday and we seem to be unable to run any analysis . The stacktrace(sonarUpgradeExecutionLog.txt) and other needed files are with the email.

As you can see, all the permissions have been provided for in the server. Also, there is a problem in running the analysis only when the user id other than admin/admin . If we use any other user id/pwassword , then it fails with a "Not authorized. Please check the properties sonar.login and sonar.password"

Can you please help us out?

Thanks & Regards,
Jitesh Dundas

Phone - <a href="tel:732-357-6292" value="+17323576292" target="_blank">732-357-6292




Reply | Threaded
Open this post in threaded view
|

Re: Sonar Analysis Issue after Upgrade

jbdundas
Hi All,

We downgraded to 4.1.2 after 4.2 did not work. It seemed to give us the issue but this time it worked after we digged in a little deeper.

Just want to let you know that we resolved this issue. I hope that this answer below helps others who might be stuck in a similar issue:-

1) We created a new user and then used it as sonar.login and sonar.password . It ran successfully.
2) After that, we updated the password for one of the existing users( not the ones that we had used and had got an error) and then let the analysis run successfully. It actually did.
3) Lastly, we used the old user accounts which were not working and it worked like a charm.

We reiterate that we have not updated any permissions ( global or project ) on this. Also, after the above change for my analysis, rest of all the other users have got their analysis working.

This is very weird behavior and looks like a bug in the 4.2 version. I hope that the Sonar team takes note of this.

Hope this helps!

Thanks & Regards,
Jitesh Dundas

Phone - 732-357-6292





On Tue, Apr 8, 2014 at 9:11 AM, jitesh dundas <[hidden email]> wrote:
Hello All,

Does anyone have any idea of the issue below? Is this a bug in the current latest version?



Thanks & Regards,
Jitesh Dundas

Phone - <a href="tel:732-357-6292" value="+17323576292" target="_blank">732-357-6292





On Mon, Apr 7, 2014 at 10:25 AM, jitesh dundas <[hidden email]> wrote:
HI All,

We upgrade our server from 3.7 to 4.2  yesterday and we seem to be unable to run any analysis . The stacktrace(sonarUpgradeExecutionLog.txt) and other needed files are with the email.

As you can see, all the permissions have been provided for in the server. Also, there is a problem in running the analysis only when the user id other than admin/admin . If we use any other user id/pwassword , then it fails with a "Not authorized. Please check the properties sonar.login and sonar.password"

Can you please help us out?

Thanks & Regards,
Jitesh Dundas

Phone - <a href="tel:732-357-6292" value="+17323576292" target="_blank">732-357-6292





Reply | Threaded
Open this post in threaded view
|

Re: Sonar Analysis Issue after Upgrade

jbdundas
All,

Due to some good features like multi-language support in 4.2, my users want me to upgrade the server from 3.7 to 4.2 and not 3.7 to 4.1.2( which seems to be more stable for us).

We are again facing the same problem and those earlier steps are not working on 4.2.

To summarize, here are the things we are facing now:-
1) None of the analysis works. It still gives us the earlier error messages.
2) I see a ticket on JIRA and a question on StackOverFlow on this:-

 

http://stackoverflow.com/questions/22967527/receiving-not-authorized-error-after-upgrading-to-sonarqube-4-2

http://jira.codehaus.org/browse/MSONAR-66


This is a blocking problem for us and we cannot proceed further with the upgrade if this issue is not resolved. Please let us know if anyone finds a solution to this problem ( or if you think this is a bug in 4.2 ).


Thank you for your help!




Thanks & Regards,
Jitesh Dundas

Phone - 732-357-6292





On Thu, Apr 10, 2014 at 11:46 AM, jitesh dundas <[hidden email]> wrote:
Hi All,

We downgraded to 4.1.2 after 4.2 did not work. It seemed to give us the issue but this time it worked after we digged in a little deeper.

Just want to let you know that we resolved this issue. I hope that this answer below helps others who might be stuck in a similar issue:-

1) We created a new user and then used it as sonar.login and sonar.password . It ran successfully.
2) After that, we updated the password for one of the existing users( not the ones that we had used and had got an error) and then let the analysis run successfully. It actually did.
3) Lastly, we used the old user accounts which were not working and it worked like a charm.

We reiterate that we have not updated any permissions ( global or project ) on this. Also, after the above change for my analysis, rest of all the other users have got their analysis working.

This is very weird behavior and looks like a bug in the 4.2 version. I hope that the Sonar team takes note of this.

Hope this helps!

Thanks & Regards,
Jitesh Dundas

Phone - <a href="tel:732-357-6292" value="+17323576292" target="_blank">732-357-6292





On Tue, Apr 8, 2014 at 9:11 AM, jitesh dundas <[hidden email]> wrote:
Hello All,

Does anyone have any idea of the issue below? Is this a bug in the current latest version?



Thanks & Regards,
Jitesh Dundas

Phone - <a href="tel:732-357-6292" value="+17323576292" target="_blank">732-357-6292





On Mon, Apr 7, 2014 at 10:25 AM, jitesh dundas <[hidden email]> wrote:
HI All,

We upgrade our server from 3.7 to 4.2  yesterday and we seem to be unable to run any analysis . The stacktrace(sonarUpgradeExecutionLog.txt) and other needed files are with the email.

As you can see, all the permissions have been provided for in the server. Also, there is a problem in running the analysis only when the user id other than admin/admin . If we use any other user id/pwassword , then it fails with a "Not authorized. Please check the properties sonar.login and sonar.password"

Can you please help us out?

Thanks & Regards,
Jitesh Dundas

Phone - <a href="tel:732-357-6292" value="+17323576292" target="_blank">732-357-6292






Reply | Threaded
Open this post in threaded view
|

Re: Sonar Analysis Issue after Upgrade

jbdundas
All,

Sending a copy of our permissions .

Thanks & Regards,
Jitesh Dundas

Phone - 732-357-6292





On Fri, Apr 11, 2014 at 12:09 PM, jitesh dundas <[hidden email]> wrote:
All,

Due to some good features like multi-language support in 4.2, my users want me to upgrade the server from 3.7 to 4.2 and not 3.7 to 4.1.2( which seems to be more stable for us).

We are again facing the same problem and those earlier steps are not working on 4.2.

To summarize, here are the things we are facing now:-
1) None of the analysis works. It still gives us the earlier error messages.
2) I see a ticket on JIRA and a question on StackOverFlow on this:-

 

http://stackoverflow.com/questions/22967527/receiving-not-authorized-error-after-upgrading-to-sonarqube-4-2

http://jira.codehaus.org/browse/MSONAR-66


This is a blocking problem for us and we cannot proceed further with the upgrade if this issue is not resolved. Please let us know if anyone finds a solution to this problem ( or if you think this is a bug in 4.2 ).


Thank you for your help!




Thanks & Regards,
Jitesh Dundas

Phone - <a href="tel:732-357-6292" value="+17323576292" target="_blank">732-357-6292





On Thu, Apr 10, 2014 at 11:46 AM, jitesh dundas <[hidden email]> wrote:
Hi All,

We downgraded to 4.1.2 after 4.2 did not work. It seemed to give us the issue but this time it worked after we digged in a little deeper.

Just want to let you know that we resolved this issue. I hope that this answer below helps others who might be stuck in a similar issue:-

1) We created a new user and then used it as sonar.login and sonar.password . It ran successfully.
2) After that, we updated the password for one of the existing users( not the ones that we had used and had got an error) and then let the analysis run successfully. It actually did.
3) Lastly, we used the old user accounts which were not working and it worked like a charm.

We reiterate that we have not updated any permissions ( global or project ) on this. Also, after the above change for my analysis, rest of all the other users have got their analysis working.

This is very weird behavior and looks like a bug in the 4.2 version. I hope that the Sonar team takes note of this.

Hope this helps!

Thanks & Regards,
Jitesh Dundas

Phone - <a href="tel:732-357-6292" value="+17323576292" target="_blank">732-357-6292





On Tue, Apr 8, 2014 at 9:11 AM, jitesh dundas <[hidden email]> wrote:
Hello All,

Does anyone have any idea of the issue below? Is this a bug in the current latest version?



Thanks & Regards,
Jitesh Dundas

Phone - <a href="tel:732-357-6292" value="+17323576292" target="_blank">732-357-6292





On Mon, Apr 7, 2014 at 10:25 AM, jitesh dundas <[hidden email]> wrote:
HI All,

We upgrade our server from 3.7 to 4.2  yesterday and we seem to be unable to run any analysis . The stacktrace(sonarUpgradeExecutionLog.txt) and other needed files are with the email.

As you can see, all the permissions have been provided for in the server. Also, there is a problem in running the analysis only when the user id other than admin/admin . If we use any other user id/pwassword , then it fails with a "Not authorized. Please check the properties sonar.login and sonar.password"

Can you please help us out?

Thanks & Regards,
Jitesh Dundas

Phone - <a href="tel:732-357-6292" value="+17323576292" target="_blank">732-357-6292









---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

soanr_upgrade_error_11Apr2014_p1.PNG (142K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Sonar Analysis Issue after Upgrade

BGone
This post has NOT been accepted by the mailing list yet.
In reply to this post by jbdundas