Sonar for C# code not working

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Sonar for C# code not working

satishKaRohini
sonarwithChashFinal.txt

I am trying to set-up my C# code on sonar and for that I have downloaded relevant C# plugins.
I ccopied the plugins to the plugin directory in sonar server.
When I start sonar server, then I get error on console and sonar doesn't start.
Looking at logs. It has below errors:
java.lang.IllegalArgumentException: Debt definition on rule 'stylecop:ElementMustBeginWithUpperCaseLetter' is invalid

Also
2014.11.14 05:23:44 ERROR web[jruby.rack]  initialization failed
org.jruby.rack.RackInitializationException: java.lang.NullPointerException
Detail logs is attached

When I remove the C# plugins then sonar server starts correctly.
I am using
sonarcube 4.5.1
Latest IKVM.NET library
C# Eco System Plugin

Interestingly I do not get this error on another machine. The only difference between 2 machines are :
Machine 1:
Has java 1.7, Windows7 and doesn't have .NET framework.
Machine 2:
Has java 1.7, WindowsXP and has .NET framework.

On Machine 1, I do not get the error. But I need to set it up on Machine 2 (as this is my customer requirement)

Thanks,
Satish
Reply | Threaded
Open this post in threaded view
|

Re: Sonar for C# code not working

Dinesh Bolkensteyn-2
You are using very old versions of the C# plugins (2.0), which is no longer supported.

I'd suggest that you restart from scratch, with the latest plugins this time.

Use the Update Center within SonarQube to be sure to download the latest compatible plugins.


On Fri, Nov 14, 2014 at 8:47 AM, satishKaRohini <[hidden email]> wrote:
sonarwithChashFinal.txt
<http://sonarqube.15.x6.nabble.com/file/n5030077/sonarwithChashFinal.txt>

I am trying to set-up my C# code on sonar and for that I have downloaded
relevant C# plugins.
I ccopied the plugins to the plugin directory in sonar server.
When I start sonar server, then I get error on console and sonar doesn't
start.
Looking at logs. It has below errors:
java.lang.IllegalArgumentException: Debt definition on rule
'stylecop:ElementMustBeginWithUpperCaseLetter' is invalid

Also
<a href="tel:2014.11.14%2005" value="+12014111405">2014.11.14 05:23:44 ERROR web[jruby.rack]  initialization failed
org.jruby.rack.RackInitializationException: java.lang.NullPointerException
Detail logs is attached

When I remove the C# plugins then sonar server starts correctly.
I am using
sonarcube 4.5.1
Latest IKVM.NET library
C# Eco System Plugin

Interestingly I do not get this error on another machine. The only
difference between 2 machines are :
Machine 1:
Has java 1.7, Windows7 and doesn't have .NET framework.
Machine 2:
Has java 1.7, WindowsXP and has .NET framework.

On Machine 1, I do not get the error. But I need to set it up on Machine 2
(as this is my customer requirement)

Thanks,
Satish



--
View this message in context: http://sonarqube.15.x6.nabble.com/Sonar-for-C-code-not-working-tp5030077.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email