SonarQube Will Not Run - No Info In Logs

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

SonarQube Will Not Run - No Info In Logs

Kyle Smith
Hi Everyone,

Something happened to my instance of SonarQube as when I restart it or start it with the sonar.sh shell script it says it starts but then when using the status command the computer prints that SonarQube is not running.

I checked the logs and nothing is here. It is definitely perplexing.

Thank-you for reading this.

Regards,

Reply | Threaded
Open this post in threaded view
|

Re: SonarQube Will Not Run - No Info In Logs

G. Ann Campbell
You say there's nothing in the logs... So it gives the normal startup message and then the normal shutdown message with nothing in between?



---
G. Ann CAMPBELL | SonarSource
Product Owner


On Fri, Aug 15, 2014 at 1:21 PM, What_Just_Happened <[hidden email]> wrote:
Hi Everyone,

Something happened to my instance of SonarQube as when I restart it or start
it with the sonar.sh shell script it says it starts but then when using the
status command the computer prints that *SonarQube is not running*.

I checked the logs and nothing is here. It is definitely perplexing.

Thank-you for reading this.

Regards,





--
View this message in context: http://sonarqube.15.x6.nabble.com/SonarQube-Will-Not-Run-No-Info-In-Logs-tp5027474.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: SonarQube Will Not Run - No Info In Logs

Patroklos Papapetrou
In reply to this post by Kyle Smith
Hi 
Can you please try this :
- Open the sonar.properties file which is located under /conf of Sonarqube installation directory and enable profile logging. You should see something like this at the end of the file

# PROFILING
# Level of information displayed in the logs: NONE (default), BASIC (functional information) and FULL (functional and technical details)
#sonar.log.profilingLevel=NONE

Uncomment the last line and change to 
sonar.log.profilingLevel=FULL

Then try to restart Sonarqube again and check your log file.


Patroklos Papapetrou

SoftwareGarden.io

Linkedin | Twitter | Author Speaker | Blog | Google+ | GitHub |




On Fri, Aug 15, 2014 at 8:21 PM, What_Just_Happened <[hidden email]> wrote:
Hi Everyone,

Something happened to my instance of SonarQube as when I restart it or start
it with the sonar.sh shell script it says it starts but then when using the
status command the computer prints that *SonarQube is not running*.

I checked the logs and nothing is here. It is definitely perplexing.

Thank-you for reading this.

Regards,





--
View this message in context: http://sonarqube.15.x6.nabble.com/SonarQube-Will-Not-Run-No-Info-In-Logs-tp5027474.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: SonarQube Will Not Run - No Info In Logs

Bernd
In reply to this post by G. Ann Campbell
You can also check for hserr_ files in the main directory, which would be a sign of a crashed VM. And also try to run java executable to see of it prints it's version and help (or an fatal corruption error message).

Bernd

Am 15.08.2014 um 19:34 schrieb "G. Ann Campbell" <[hidden email]>:

You say there's nothing in the logs... So it gives the normal startup message and then the normal shutdown message with nothing in between?



---
G. Ann CAMPBELL | SonarSource
Product Owner


On Fri, Aug 15, 2014 at 1:21 PM, What_Just_Happened <[hidden email]> wrote:
Hi Everyone,

Something happened to my instance of SonarQube as when I restart it or start
it with the sonar.sh shell script it says it starts but then when using the
status command the computer prints that *SonarQube is not running*.

I checked the logs and nothing is here. It is definitely perplexing.

Thank-you for reading this.

Regards,





--
View this message in context: http://sonarqube.15.x6.nabble.com/SonarQube-Will-Not-Run-No-Info-In-Logs-tp5027474.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: SonarQube Will Not Run - No Info In Logs

Kyle Smith
Hi Friends,

I actually rm'd my previous sonar.log file under logs and created another one and then found an error pertaining to the jvm not being able to start because an issue with the file system. I obtained some help though and everything is working again.

Thank-you everyone for the help. I sincerely appreciate it.

Regards,