fb-contrib plugin and SonarQube 4.4 Shutting Down Server

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

fb-contrib plugin and SonarQube 4.4 Shutting Down Server

Kyle Smith
Hello SQ-User Community,

I just upgraded SonarQube to 4.4 and tried re-installing the find-bugs plugin (fb-contrib). I restarted the server and everything was going fine until I tried to access the web-interface with my web-browser. At this point the application shut-down. Does anyone know why this is happening?

Thank-you for reading this.

Regards,

Reply | Threaded
Open this post in threaded view
|

Re: fb-contrib plugin and SonarQube 4.4 Shutting Down Server

G. Ann Campbell
Is there anything relevant-seeming in your server log?



---
G. Ann CAMPBELL | SonarSource
Product Owner


On Wed, Aug 13, 2014 at 2:59 PM, What_Just_Happened <[hidden email]> wrote:
Hello SQ-User Community,

I just upgraded /SonarQube/ to 4.4 and tried re-installing the find-bugs
plugin (/fb-contrib/). I restarted the server and everything was going fine
until I tried to access the web-interface with my web-browser. At this point
the application shut-down. Does anyone know why this is happening?

Thank-you for reading this.

Regards,





--
View this message in context: http://sonarqube.15.x6.nabble.com/fb-contrib-plugin-and-SonarQube-4-4-Shutting-Down-Server-tp5027396.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: fb-contrib plugin and SonarQube 4.4 Shutting Down Server

Kyle Smith
Hi Ann,

Thank-you for the helpful reply. I checked the log file and found this helpful tidbit: org.sonar.api.utils.SonarException: Fail to extend the plugin findbugs for fbcontrib

I looked up this problem on Google and saw that other people faced this issue but with an upgrade. I am starting out on a completely fresh database though, which is a totally different situation.

Do you have any idea on how I can use the findbugs plugin with the latest version of SonarQube, 4.4 as of this writing?

Regards,


Reply | Threaded
Open this post in threaded view
|

Re: fb-contrib plugin and SonarQube 4.4 Shutting Down Server

Evgeny Mandrikov
Hi,

If you're using Findbugs plugin version 2.4 or greater, then you don't need to install fb-contrib in addition, because since this version it's no more a separate plugin - see http://www.sonarsource.com/2014/08/05/sonarqube-findbugs-2-4-released/
So the question is - which exact combination of versions do you try to use?


On Wed, Aug 13, 2014 at 9:23 PM, What_Just_Happened <[hidden email]> wrote:
Hi Ann,

Thank-you for the helpful reply. I checked the log file and found this
helpful tidbit: *org.sonar.api.utils.SonarException: Fail to extend the
plugin findbugs for fbcontrib*

I looked up this problem on Google and saw that other people faced this
issue but with an upgrade. I am starting out on a completely fresh database
though, which is a totally different situation.

Do you have any idea on how I can use the findbugs plugin with the latest
version of SonarQube, 4.4 as of this writing?

Regards,






--
View this message in context: http://sonarqube.15.x6.nabble.com/fb-contrib-plugin-and-SonarQube-4-4-Shutting-Down-Server-tp5027396p5027398.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_
Reply | Threaded
Open this post in threaded view
|

Re: fb-contrib plugin and SonarQube 4.4 Shutting Down Server

Kyle Smith
Evgeny,

Thank-you for the interesting and helpful reply. I do not see FindBugs as an option to download by itself in the upgrade center.

Is this an error in the software or is the end-user supposed to download from an outside source to obtain the FindBugs plugin?  Like here for instance: http://docs.codehaus.org/display/SONAR/FindBugs+Plugin 


Regards,

Reply | Threaded
Open this post in threaded view
|

Re: fb-contrib plugin and SonarQube 4.4 Shutting Down Server

Alexandre GIGLEUX-2
Hi,

For me you need to upgrade the Java Plugin as proposed in the Update Center. This will download sonar-java-plugin-2.4.jar & sonar-findbugs-plugin-3.0.jar at the same time.
Before restarting SQ 4.4, you need to remove from extensions/plugins the following files: sonar-surefire-plugin-2.2.1.jar, sonar-squid-java-plugin-2.2.1.jar & sonar-jacoco-plugin-2.2.1.jar as mentioned in red here: http://docs.codehaus.org/display/SONAR/Java+Plugin

If you don't want to analyze Java 8 and can't run SQ using JRE 1.7, you need to downgrade manually sonar-findbugs-plugin from 3.0 to 2.4 by downloading it from http://docs.codehaus.org/display/SONAR/FindBugs+Plugin
Then you can restart SQ.

Alex


On Wed, Aug 13, 2014 at 9:56 PM, What_Just_Happened <[hidden email]> wrote:
Evgeny,

Thank-you for the interesting and helpful reply. I do not see *FindBugs* as
an option to download by itself in the upgrade center.

Is this an error in the software or is the end-user supposed to download
from an outside source to obtain the *FindBugs* plugin?  Like here for
instance: http://docs.codehaus.org/display/SONAR/FindBugs+Plugin


Regards,





--
View this message in context: http://sonarqube.15.x6.nabble.com/fb-contrib-plugin-and-SonarQube-4-4-Shutting-Down-Server-tp5027396p5027401.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: fb-contrib plugin and SonarQube 4.4 Shutting Down Server

Evgeny Mandrikov
In reply to this post by Kyle Smith
Findbugs Plugin version 2.4 was extracted from Java Plugin and so requires Java Plugin version 2.4, which is unfortunately can't be installed automatically as stated on page http://docs.codehaus.org/display/SONAR/Java+Plugin

On Wed, Aug 13, 2014 at 9:56 PM, What_Just_Happened <[hidden email]> wrote:
Evgeny,

Thank-you for the interesting and helpful reply. I do not see *FindBugs* as
an option to download by itself in the upgrade center.

Is this an error in the software or is the end-user supposed to download
from an outside source to obtain the *FindBugs* plugin?  Like here for
instance: http://docs.codehaus.org/display/SONAR/FindBugs+Plugin


Regards,





--
View this message in context: http://sonarqube.15.x6.nabble.com/fb-contrib-plugin-and-SonarQube-4-4-Shutting-Down-Server-tp5027396p5027401.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_
Reply | Threaded
Open this post in threaded view
|

Re: fb-contrib plugin and SonarQube 4.4 Shutting Down Server

Kyle Smith
In reply to this post by Alexandre GIGLEUX-2
Hi Alex,

I found that installing the Java plugin with the Findbugs plugin worked. I installed Findbugs from here:http://docs.codehaus.org/display/SONAR/FindBugs+Plugin 

The Java plugin I found on the 'Available Plugins' page in the Update Center though.

I needed to install both the Java plugin and Findbugs. As Findbugs does not work without the Java plugin.

I was not aware that downloading the sonar-java-plugin-2.4.jar would also download sonar-findbugs-plugin-3.0.jar. Thank-you Alex for replying with this information.

Regards,