[sonar-dev] [ANN] Sonar Maven Plugin 1.0-beta-2

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[sonar-dev] [ANN] Sonar Maven Plugin 1.0-beta-2

Simon Brandhof-2
The Sonar team is pleased to announce the release of Sonar Maven Plugin, version 1.0-beta-2. 
It makes configuration easier when using a repository manager like Archiva or Nexus. Indeed no additional settings are required anymore ! Let's remind that the version 1.0-beta-1 needs to declare a mirror in maven settings or to add a new repository to the manager.

This improvement requires Sonar 2.2+. It is automatically disabled when using sonar 2.1 or less. Upgrading to this version should be automatic if the shortcut "mvn sonar:sonar" or the hudson plugin are used.

Simon Brandhof
Reply | Threaded
Open this post in threaded view
|

Re: [sonar-dev] [ANN] Sonar Maven Plugin 1.0-beta-2

Josh Cummings
Well done! I have a question, though.

We are still on 2.0.1, and when we built this morning, 1.0-beta-2 was downloaded.  It seems from your description that it should have kept 1.0-beta-1.  Am I mistaken?

Josh

On Mon, Sep 13, 2010 at 9:59 AM, Simon Brandhof <[hidden email]> wrote:
The Sonar team is pleased to announce the release of Sonar Maven Plugin, version 1.0-beta-2. 
It makes configuration easier when using a repository manager like Archiva or Nexus. Indeed no additional settings are required anymore ! Let's remind that the version 1.0-beta-1 needs to declare a mirror in maven settings or to add a new repository to the manager.

This improvement requires Sonar 2.2+. It is automatically disabled when using sonar 2.1 or less. Upgrading to this version should be automatic if the shortcut "mvn sonar:sonar" or the hudson plugin are used.

Simon Brandhof

Reply | Threaded
Open this post in threaded view
|

Re: [sonar-dev] [ANN] Sonar Maven Plugin 1.0-beta-2

Simon Brandhof

We are still on 2.0.1, and when we built this morning, 1.0-beta-2 was downloaded.  It seems from your description that it should have kept 1.0-beta-1.  Am I mistaken?

 
It's the expected behavior. 1.0-beta-2 supports all sonar versions.