sonar not displaying all the packages while clicking on coverage percentage

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

sonar not displaying all the packages while clicking on coverage percentage

softwareforums2013
Hi Sonar,

I have moved from cobertura to jacoco code coverage. Doing so code coverage has decreased by 0.9%. I was doing some analysis on it and have found below things:

1. when I click on code coverage, I dont see all the classes or packages (using jacoco) but when I had done the sonar analysis using cobertura I see all the classes or packages.

The only thing I have changed in my pom.xml are the code coverage property tags.

2. I was looking at the logs and saw [WARNING] class 'xxx' is not accessible through class loader. So, does this means that if it is not accessible through class loader it doesnt show up in sonar while clicking on code coverage.

Why am I not being able to see all the classes on sonar after I click on code coverage percentage?

In my pom.xml I have mentioned the path those src.
Reply | Threaded
Open this post in threaded view
|

Re: sonar not displaying all the packages while clicking on coverage percentage

softwareforums2013
I see that warning message class "XXX" is not accessible through class loader when I run the sonar analysis with cobertura too. So, I guess this is not the reason why it is not showing up all the classes or packages
Reply | Threaded
Open this post in threaded view
|

Re: sonar not displaying all the packages while clicking on coverage percentage

David Racodon-2


David RACODON | SonarSource
Senior Consultant

---------------------------------------------
  Sign up to our newsletter here!
---------------------------------------------


On Fri, Jan 10, 2014 at 6:31 PM, softwareforums2013 <[hidden email]> wrote:
I see that warning message class "XXX" is not accessible through class loader
when I run the sonar analysis with cobertura too. So, I guess this is not
the reason why it is not showing up all the classes or packages



--
View this message in context: http://sonarqube.15.x6.nabble.com/sonar-not-displaying-all-the-packages-while-clicking-on-coverage-percentage-tp5020911p5020913.html
Sent from the SonarQube Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email